V2RayX配置教程

本文转载自:https://v2raytech.com/v2rayx-config-tutorial/,如文中内容有错误请到原文查看原始版(最新版)

阅读本教程的前提:

  1. 已有服务端信息,可参考 获取科学上网服务端信息
  2. 下载V2rayX,未下载的请到这个页面下载:V2Ray苹果客户端下载

V2rayX是一个基于V2ray核心的mac系统客户端,但gui界面不支持配置shadowsocks,并且界面都是英文。

操作步骤

1. 解压下载的压缩包,得到V2rayX.app文件,将其拖入“应用程序”文件夹中;

2. 在“启动台”中找到V2rayX,点击打开,首次打开会有安全提示框中,点击“好“:

V2rayX安全提示

V2rayX安全提示

然后打开“系统偏好设置” -> “安全性与隐私” ,点击下方的“仍要打开”:

V2rayX安全性与隐私

V2rayX安全性与隐私

在新出来的授权弹框中输入登录账户密码,会再出现确认提示框,点击“打开”:

V2rayX确认框

V2rayX确认框

3. 点击上方状态栏的V2rayX图标,出现主菜单栏:

V2rayX主菜单

V2rayX主菜单

4. 点击配置(configure),进入服务器配置界面:

V2rayX服务器配置界面

V2rayX服务器配置界面

5. 根据服务器信息,输入ip或者域名(address)、端口,用户id(user id)、额外id(alterid)(不知道这些信息填什么请参考参考 获取科学上网服务端信息)。安全性一般为auto,在备注(tag)里输一个好记的名字。然后选择承载网络(network),一般是tcp。

Just My Socks V2ray加密方式选none或者auto上不了网,请改成chacha20-ietf-poly1305

如果用了伪装(没用就不要填!),点击传输层设置(transport settings)进入高级设置界面,在”websocket”中填写伪装路径、主机名(host),在TLS中勾选“use tls”,同时勾选”tls allow insecureciphers”和”tls allowinscure”两项,在tls servername中填入主机名。

如果使用中出现问题,可将日志等级(log level)调成info,然后可以点击show log查看日志。配置好后点击ok保存配置。

6. 建议在主界面勾选pac模式(pac mode),然后点击加载(load core)启动软件。

配置无误且到服务端网络畅通的话,打开浏览器应该就可以愉快的访问youtube的网站了。

如遇到问题,请在页面下方留言。

参考

1. V2ray教程

2. V2ray高级技巧:流量伪装

3. V2ray带伪装一键脚本

《V2RayX配置教程》上有16条评论

  1. 我也是按这样配置了,我用的是订阅地址的方式,自动获取了服务器列表,但是依旧上不了不知道为啥呢?同样的订阅地址,我在windows里的v2rayN正常,安卓的也正常,iOS里的也正常,唯独Mac里的这个v2rayX就是上不了。不知道哪里配的不对?我看config里,TLS是开启了的。

    1. 为什么我导入了节点后,点ok,弹出警告框,说我两个节点共享标识,怎么处理

  2. vps安装好后,本地telnet可以通,但安装v2rayX客户端后,无法翻墙,报错:v2ray.com/core/app/proxyman/outbound: failed to process outbound traffic > v2ray.com/core/proxy/vmess/outbound: connection ends > v2ray.com/core/proxy/vmess/outbound: failed to read header > v2ray.com/core/proxy/vmess/encoding: failed to read response header > EOF

  3. 您好,请问一直有这个报错要怎么处理呀?
    proxy/vless/outbound: failed to use xtls-rprx-direct, maybe “security” is not “xtls”

  4. 紧急求助楼主,我用您的一键脚本选择了安装Xray-VLESS+TCP+XTLS,请问我应该如何把信息填到V2RayXS 或者 V2RayX?对着(https://v2xtls.org/v2rayx%E9%85%8D%E7%BD%AE%E6%95%99%E7%A8%8B/)测试了很多次都失败了。。我最近电脑macOS更新上不了小火箭了,太难受。

  5. 破案了,目前Xray一键脚本选择了安装Xray-VLESS+TCP+XTLS使用V2RayXS需要旧版本v1.5.6。v1.5.7需要xray core update to 1.8.0

发表回复

您的电子邮箱地址不会被公开。 必填项已用*标注